Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: I get an error when signing into my admin panel after upgrading to v.1.1.3  (Read 6100 times)

Offline denagpam

  • Full Member
  • ***
  • Posts: 103
  • Karma: +7/-9
    • View Profile
Dear admin,

I have upgraded to v.1.1.3. But, I get an error when I try to sign into my admin panel:

after I browse to: http://goolysmart.web.id/index.php?s=gs_admin

There is an error:

"Fatal error: Call to a member function replaceDescriptions() on a non-object in /home/goolysma/public_html/admin/model/localisation/language_definitions.php on line 50"

Then, I do no know where I must locate upgrade.php file. Must it be located to public_html?

If so, I have done this, but, after I browse to goolysmart.web.id/upgrade.php, I get this error:

"There has been an error processing your request

Please check error log for more info. You can check error log in the control panel if it is functional. Otherwise, refer to error log located in your web server
Go to main page"

Hope you help me fix this issue.

Thanks.
« Last Edit: January 31, 2013, 04:47:10 PM by denagpam »

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1891
  • Karma: +290/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
HI.
if you upgraded from 1.1.2 to 1.1.3 you have to do:

1. download package http://abantecart.googlecode.com/files/abantecart_1.1.3_upgrade_only.tar.gz and unpack.
2. replace all php files into your public_html directory by files of folder "code".
3. delete all files from folder public_html/system/cache except index.html
4. also check is file core/engine/language.php exists

“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Nimitz1061

  • Full Member
  • ***
  • Posts: 190
  • Karma: +21/-0
  • No matter where you go, there you are...
    • View Profile
Re: I get an error when signing into my admin panel after upgrading to v.1.1.3
« Reply #2 on: February 02, 2013, 07:53:39 AM »
I have the same issue.

I have done all of the things you listed.

The problem remains.

David

Offline Nimitz1061

  • Full Member
  • ***
  • Posts: 190
  • Karma: +21/-0
  • No matter where you go, there you are...
    • View Profile
Re: I get an error when signing into my admin panel after upgrading to v.1.1.3
« Reply #3 on: February 02, 2013, 07:54:31 AM »
Also,  your listed steps do not include information on what to do with the upgrade.php file which is located above the code/ folder.

David

Offline Nimitz1061

  • Full Member
  • ***
  • Posts: 190
  • Karma: +21/-0
  • No matter where you go, there you are...
    • View Profile
Re: I get an error when signing into my admin panel after upgrading to v.1.1.3
« Reply #4 on: February 02, 2013, 08:14:55 AM »
Looking at the files in the upgrade only tarball, I see that there is NO public_html/core/version.php file.

Adding this does not fix the problem however...



Offline Nimitz1061

  • Full Member
  • ***
  • Posts: 190
  • Karma: +21/-0
  • No matter where you go, there you are...
    • View Profile
Re: I get an error when signing into my admin panel after upgrading to v.1.1.3
« Reply #5 on: February 02, 2013, 09:37:19 AM »
Further, looking at the upgrade.php file, I checked the conditions that the file looks for in the database, and did not find them.

In my case at least, this would seem to be immaterial to the fatal error..

Offline Nimitz1061

  • Full Member
  • ***
  • Posts: 190
  • Karma: +21/-0
  • No matter where you go, there you are...
    • View Profile
Re: I get an error when signing into my admin panel after upgrading to v.1.1.3
« Reply #6 on: February 02, 2013, 10:05:45 AM »
setting auto_translate_status to '0' in phpMyAdmin also fails to address this.

Offline denagpam

  • Full Member
  • ***
  • Posts: 103
  • Karma: +7/-9
    • View Profile
Re: I get an error when signing into my admin panel after upgrading to v.1.1.3
« Reply #7 on: February 03, 2013, 08:40:49 PM »
Mr. David, thanks very much for your attention to this issue. I know that you are one of the abantecart's admin. I hope Mr. abolabo will give a response this. Thanks.
« Last Edit: February 03, 2013, 09:19:39 PM by denagpam »

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1891
  • Karma: +290/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: I get an error when signing into my admin panel after upgrading to v.1.1.3
« Reply #8 on: February 04, 2013, 10:54:10 PM »
i confirm. it's a bug.
please replace lines
Code: [Select]
//load main language section
$language->load();
$registry->set('language', $language);
by this
Code: [Select]
//load main language section
$registry->set('language', $language);
        $registry->get('language')->load();

thanks to denagpam for help.
1.1.4 will be released soon.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline denagpam

  • Full Member
  • ***
  • Posts: 103
  • Karma: +7/-9
    • View Profile
Re: I get an error when signing into my admin panel after upgrading to v.1.1.3
« Reply #9 on: February 05, 2013, 04:54:15 PM »
Thank you very much for your help, Mr. Abolabo.

 

Powered by SMFPacks Social Login Mod