Shopping Cart Operations > Security

jQuery before 3.0.0 is vulnerable to XSS


While working to obtain PCI compliance on a site  all tests have been successfully passed except for one. 

CVE-2015-9251 fails with this notification:

jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when across-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed.

It looks like 1.2.12  version is using jQuery 1.12.4.  jQuery site states that verions 1.x and 2.x are no longer receiving patches.  Do you anticipate upgrading to 3.x  with the next AbanteCart version 1.2.13?

Info regarding the issue can be found here:

Any feedback on this would be appreciated.


Any suggestions,   remarks,  insights,  or possible changes?


Hi, llegrand.
I don't think that JQuery will be updated in 1.2.13


[0] Message Index

Go to full version
Powered by SMFPacks Social Login Mod