Author Topic: how to fix set_time_limit() has been disabled for security reasons  (Read 4080 times)

CTGO.co

  • Guest
how to fix set_time_limit() has been disabled for security reasons ??

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4819
  • Karma: +253/-2
    • View Profile
Re: how to fix set_time_limit() has been disabled for security reasons
« Reply #1 on: December 11, 2018, 08:28:46 AM »
It is just a waring and should be not critical for most of the AbanteCart functionality
anyway this is related to hosting server setup https://stackoverflow.com/questions/17434013/set-time-limit-has-been-disabled-for-security-reasons

CTGO.co

  • Guest
Re: how to fix set_time_limit() has been disabled for security reasons
« Reply #2 on: December 11, 2018, 09:44:13 AM »
It is just a waring and should be not critical for most of the AbanteCart functionality
anyway this is related to hosting server setup https://stackoverflow.com/questions/17434013/set-time-limit-has-been-disabled-for-security-reasons

hosting company says that if i want best result i should edit php.ini file. can you tell me how to do the best values in that file please??

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4305
  • Karma: +288/-10
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: how to fix set_time_limit() has been disabled for security reasons
« Reply #3 on: December 12, 2018, 09:37:30 PM »
Your host has safe mode enabled and they do no allow for resting the time limit with safe mode enabled.

Check if you have safe_mode in your php.ini.
If you do, set it to:
safe_mode = Off

For execution time, you can to edit max_execution_time setting in your php.ini



Please  rate your experience or leave your review
We need your help to build better free open source ecommerce platform for everyone. See how you can help

CTGO.co

  • Guest
Re: how to fix set_time_limit() has been disabled for security reasons
« Reply #4 on: December 13, 2018, 03:05:39 AM »
Your host has safe mode enabled and they do no allow for resting the time limit with safe mode enabled.

Check if you have safe_mode in your php.ini.
If you do, set it to:
safe_mode = Off

For execution time, you can to edit max_execution_time setting in your php.ini

thank you Sir, tell me please, what is the best interval on max_execution_time ?
« Last Edit: December 13, 2018, 03:46:35 AM by CTGO.co LLC »

CTGO.co

  • Guest
Re: how to fix set_time_limit() has been disabled for security reasons
« Reply #5 on: December 13, 2018, 03:19:32 AM »
Your host has safe mode enabled and they do no allow for resting the time limit with safe mode enabled.

Check if you have safe_mode in your php.ini.
If you do, set it to:
safe_mode = Off

For execution time, you can to edit max_execution_time setting in your php.ini

;Use this file for specific PHP settings on your server required for AbanteCart.

output_buffering = 4096;
magic_quotes_gpc = Off;
register_globals = Off;
default_charset   = UTF-8;
memory_limit = 128M;
max_execution_time = 18000;
upload_max_filesize = 100M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 12000000;
apc.enabled = 0;


this is the code in my php.ini
is it ok or i should change something here??

CTGO.co

  • Guest
Re: how to fix set_time_limit() has been disabled for security reasons
« Reply #6 on: December 18, 2018, 03:18:38 AM »
 i edited : max_execution_time = 36000;  is that ok ??

 

Powered by SMFPacks Social Login Mod