Shopping Cart Operations > Support

Stripe does not work on 1.12.16

(1/4) > >>

Hi, I upgraded from 1.12.15 to 1.12.16 earlier and at checkout the Stripe card entry box was unusable. It looked small and thin, was unclickable, and could not be tabbed into from the previous input box.

The extension version is 1.0.4. I have tried manually overwriting the extension with the one from the source, and there were a few files that reported as different sizes, but most were the same.

This did not resolve the issue. Looking at Chrome debug I could see a jquery exception regarding something being undefined. I deleted the 1.0.4 extension and replaced it with the 1.0.3 version from my 1.12.15 backup, and this works.

I would like to get onto 1.0.4 though for 3D Secure and PCI DSS Compliance. It does not look as though I am the only one this has happened to, as there is a recent comment on the Advanced Stripe extension whereby a user reports the same issue with that extension. Just for clarity, I am not referring to the Advanced Stripe extension for my query, just felt it worth noting that this issues seems to affect both the default Stripe and a third party extension.

Do you use standard/default Stripe extension or third party?
If it is a default Stripe, try to clear browser cache or different browser.

If this does not help, can you please post a link to your store?

Hi, I am using default Stripe. The issue has also been reported by a user of the third party plugin, so it appears to affect both extensions.

I tried clearing caches, clearing site cache, browser cache, tried a different browser, and even went as far as loading it on a remote computer that had never accessed my site.

Unfortunately a link to my store will not help as I have worked around it by replacing the extension with version 1.0.3 from my previous backup, so appears to be functional now.

What I have noticed since then it that each time I pressed the button to make the payment without entering any info for Stripe, it generated and incomplete order on my Stripe account. When Stripe is functional it does not allow you to proceed without entering card info. I don't know if that is of any use?

I did check logs and set to debug level but unfortunately nothing was logged in Abantecart to aid diagnosis.

I am interested to know about the problem. Did you get any errors in the log?

Hello, UK-R.
AbanteCart team investigating the issue and will provide a fix soon.


[0] Message Index

[#] Next page

Go to full version
Powered by SMFPacks Social Login Mod