Author Topic: Not receiving email when message sent  (Read 2571 times)

Offline dvagner

  • Core/UI Developer
  • Jr. Member
  • **
  • Posts: 51
  • Karma: +23/-0
    • View Profile
Re: Not receiving email when message sent
« Reply #15 on: July 22, 2020, 05:26:37 AM »
Check logs your email server.
Php work correct.

Offline barry819

  • Newbie
  • *
  • Posts: 48
  • Karma: +4/-1
    • View Profile
Re: Not receiving email when message sent
« Reply #16 on: July 22, 2020, 11:11:44 AM »
There is not a problem with my email server. I receive every other email that I am supposed to receive. I ONLY do not receive the emails that contain the content of Enquirys left via my contact form. I receive the emails telling me someone LEFT an Enquiry, but not  the enquiry itself.  If these was a problem with the email server I would get NO emails from Abantecart.

The problem is in Abantecart, it is not external.

It worked correctly prior to upgrading to 1.2.16, and I have made no changes to my email address or server since then. This is 100% a problem in the "upgrade".

Offline dvagner

  • Core/UI Developer
  • Jr. Member
  • **
  • Posts: 51
  • Karma: +23/-0
    • View Profile
Re: Not receiving email when message sent
« Reply #17 on: July 22, 2020, 12:00:26 PM »
If you do want to help us with investigation you have an option to use AbanteCart paid support  http://managed.abantecart.com/

Offline barry819

  • Newbie
  • *
  • Posts: 48
  • Karma: +4/-1
    • View Profile
Re: Not receiving email when message sent
« Reply #18 on: July 22, 2020, 12:35:25 PM »
I've given you everything you have asked for that you have explained clearly enough for me to find and attach. If there is something else I can submit, tell me what it is and where to find it and I will attach whatever you want.

This problem, however, is one that did not exist in 1.2.15, but started when I upgraded to 1.2.16.

There is something in the programming - I am NOT a programmer - that creates emails and routes them. It is routing all the other emails correctly, but whatever triggers an email when a customer uses the "Contact us" form, is not causing the content of that "Contact us" message to be sent to my connected email. A message is created that tells em a customer has made a contact, but the message content is not forwarded. That WAS being done in 1.2.15, but is not being done in 1.2.16.

I receive both an email that tells me an order has been placed, AND an email that contains the body of the order. So the system is working correctly there, but not for use of the contact form.

This really is such a basic, necessary feature that it should be a HUGE priority for you to get it fixed.

Offline maxter

  • Full Member
  • ***
  • Posts: 188
  • Karma: +62/-0
    • View Profile
Re: Not receiving email when message sent
« Reply #19 on: July 22, 2020, 01:02:05 PM »
barry819, if you think it is a bug, you should report this to the AbanteCart team in a github.

https://github.com/abantecart/abantecart-src/issues

I know they resolve issues fast.

Offline barry819

  • Newbie
  • *
  • Posts: 48
  • Karma: +4/-1
    • View Profile
Re: Not receiving email when message sent
« Reply #20 on: July 22, 2020, 02:19:02 PM »
barry819, if you think it is a bug, you should report this to the AbanteCart team in a github.

https://github.com/abantecart/abantecart-src/issues

I know they resolve issues fast.

Thanks, I will give that a try.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1866
  • Karma: +285/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Not receiving email when message sent
« Reply #21 on: July 24, 2020, 07:49:12 AM »
all looks like you have some email-server issue,
1. Do you use some  "ms outlook" mail-server (mailer)?
2. Did you tried to set another email address for "contact us" form?
3. Is your receiver email-box  can recieve emails at all?
4. Did you tried to set some another mailer in the settings of AbanteCart (for example gmail etc)?

Unfortunately we have not all configutations to test.
Can you provide credentials via private message to debug yours?
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline barry819

  • Newbie
  • *
  • Posts: 48
  • Karma: +4/-1
    • View Profile
Re: Not receiving email when message sent
« Reply #22 on: July 24, 2020, 11:06:25 AM »
I will send you a private message.

1. No, I do not use an Outlook email server. I have emails being sent to  an outlook address. But it is receiving all the other emails FROM my Abantecart store just fine.
2. I have tried setting a different email in my notification settings. That did not help. I also have SMS set in my notifications for enquiries, but never get an SMS to my phone.
3. Yes, I receive order notifications, out of stock notifications, new customer registrations and all other Abantecart notifications at that same email address.
4. I do not have any idea what you mean by that. I am able to set email addresses in the Notifications menu. All are working except Enquiries, with the exact same email address set. Enquiries and New Orders also have SMS set, but I do not receive texts to my phone.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1866
  • Karma: +285/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Not receiving email when message sent
« Reply #23 on: July 29, 2020, 08:49:38 AM »
1. No, I do not use an Outlook email server. I have emails being sent to  an outlook address. But it is receiving all the other emails FROM my Abantecart store just fine.

No. You have email forwarder to outlook.com server.
This issue is NOT RELATED to AbanteCart Code.
Please ask your hosting provider about email redirects and why it's not works correctly.


“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

 

Powered by SMFPacks Social Login Mod