Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: Home Button not directing properly  (Read 412 times)

Offline Andrew Wolczyk

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Home Button not directing properly
« on: November 06, 2020, 05:28:25 AM »
I just installed AbanteCart for the first time.  Everything seems to be working fine apart from the Home button and logo image.  When I click on either of these they direct me to mydomain/my_subfolder/install/  I need them to direct me to mydomain/my_subfolder/index.php  Which file do I need to modify to get these to direct to the right place? Any help appreciated.

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1627
  • Karma: +464/-3
    • View Profile
Re: Home Button not directing properly
« Reply #1 on: November 06, 2020, 09:57:19 AM »
Seems you might have installed manually

After the Installation

    Once the installation is complete, it is strongly recommended that you bookmark or remember your control panel link. Delete install directory from your AbanteCart installation and set only read permission for the system/config.php and /index.php file! Set with 644 or 640 permissions (444, or even 400 depending on your server setup). Only working directories needs to be 777 as cache, resources, images, logs. PHP files should not be 777 on live site.

the above is from the manual (link is in the header of this forum)
https://abantecart.atlassian.net/wiki/spaces/AD/pages/4391051/Regular+Installation

Welcome to AbanteCart.

Offline Andrew Wolczyk

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Re: Home Button not directing properly
« Reply #2 on: November 06, 2020, 10:48:33 AM »
Thank you for coming back to me.  I did a one-click install from my web provider so the whole process was automated as far as I was concerned.  I did delete the install folder and, now you have pointed me in the right direction, I am changing the permissions on the files outlined.  However this still won't stop the site redirecting back to the install folder will it?  I think I'm going to have to go into the code and change the redirect manually.  BTW I have used the update module to update the site to the latest version.  I'm almost ready to go live I just need to change this redirect.

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1627
  • Karma: +464/-3
    • View Profile
Re: Home Button not directing properly
« Reply #3 on: November 06, 2020, 11:55:41 AM »
did you install with https?  or only http?   If https,  are both of your urls in the system - settings - system using the correct url?

there is a link to the htaccess for rewrite

https://abantecart.atlassian.net/wiki/spaces/AD/pages/7962664/SEO+URL+s


Offline Andrew Wolczyk

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Re: Home Button not directing properly
« Reply #4 on: November 06, 2020, 12:22:17 PM »
Thanks for the follow up. 

I installed with https  and both urls in the settings are showing https. 

I installed the software into a subfolder.  Is the .htaccess file the one that is located in mydomain/my_subfolder/.htaccess ?

If it is I can't see anything wrong with it (although I'm not really sure what I'm doing).

I was expecting it to be a php file with some code that pointed to /install/ 

Offline Andrew Wolczyk

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Re: Home Button not directing properly
« Reply #5 on: November 06, 2020, 01:25:35 PM »
Problem sorted!  It turns out I need to clear the cache on my PC.  Nothing wrong with the software at all - it was a faulty human.

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1627
  • Karma: +464/-3
    • View Profile
Re: Home Button not directing properly
« Reply #6 on: November 06, 2020, 11:47:39 PM »
happy to hear you are fixed.

Yes ,  Abantecart has a robust caching ,  and when doing changes within the admin side,  clearing cache is a good thing.  And one I often forget, too.


Offline merlonmi

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
    • wasfressen
Re: Home Button not directing properly
« Reply #7 on: November 08, 2020, 05:33:49 PM »
Have they been able to fix it? It gave me the same problem, but I did not know what it was

 

Powered by SMFPacks Social Login Mod