Author Topic: Various issues with ver 1.1.7  (Read 189 times)

Offline peter_li64

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Various issues with ver 1.1.7
« on: April 15, 2021, 12:36:43 PM »
Hi,

I have 3 issues but I'm not sure whether they are connected.

1. For a few weeks I am getting this message from PayPal:

Hi Stylo Sports ,
Please check your server that handles PayPal Instant Payment Notification (IPN) messages. Messages sent to the following URL(s) aren't being received:

h t t p : //www.stylosports.com/index.php?rt=extension%2Fdefault_pp_standart%2Fcallback

If you don't recognise this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information.
Once you or your service provider fix this problem, you or your service provider can resend the failed messages from the IPN History page. If this problem continues, PayPal may disable the IPN feature for your account.
Thank you for helping resolve this issue.

2. I am getting this constantly on my error log:

2021-04-15 16:16:03 - DEPRECATED:  AbanteCart core v.1.1.7 mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in <b>/home/customer/www/stylosports.com/public_html/core/database/mysql.php</b> on line <b>46</b>

What should I do? I haven't upgraded as I'm scared that the site won't come back up!

3. None of my recent orders are appearing in my orders list, the only way I can see there is an order is I get a message directly from PayPal saying someone has sent me money!

I would appreciate some help.

Cheers

Pete

Offline timlight10

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +8/-0
    • View Profile
    • Dedicated Presentation Solutions
Re: Various issues with ver 1.1.7
« Reply #1 on: April 15, 2021, 09:52:22 PM »
Pete v1.1.7 was released 24 September 2013, which was almost 10 years ago. You should seriously consider upgrading to 1.2.16 since, as you have pointed out, your web host will soon disable the mysql extension and then your site will be dead.

Offline peter_li64

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Various issues with ver 1.1.7
« Reply #2 on: April 16, 2021, 01:49:44 AM »
Hey Tim,

Yeah I get that but I inherited this site from the person who owned the company before me and I've no idea what the steps are to upgrade it and to be honest I'm scared that the operation will kill the site anyway, I'm sort of caught between a rock and a hard place...

Can I do an in-place upgrade without any issues?

The hosting company does do a daily backup of the whole site so I guess I could revert to a previous day if it really goes south :)

Cheers

Pete

Offline HADY

  • Full Member
  • ***
  • Posts: 210
  • Karma: +18/-4
    • View Profile
Re: Various issues with ver 1.1.7
« Reply #3 on: April 16, 2021, 09:54:12 AM »
Hey Tim,

Yeah I get that but I inherited this site from the person who owned the company before me and I've no idea what the steps are to upgrade it and to be honest I'm scared that the operation will kill the site anyway, I'm sort of caught between a rock and a hard place...

Can I do an in-place upgrade without any issues?

The hosting company does do a daily backup of the whole site so I guess I could revert to a previous day if it really goes south :)

Cheers

Pete


you will need to download the last version from next link: https://github.com/abantecart/abantecart-src then on FTP you will need to upload your public_html folder to your hosting server. You will need to backup that folder and download it to your PC with DB and upload them as I said.



you can check the posts here, you will find a lot of post about upgrading your version.

I advise you to learn on subdomain how to install the last version then you will be able to act on your website correctly.


 
« Last Edit: April 16, 2021, 09:58:55 AM by HADY »
-----------------------------
Regards
HADY

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4305
  • Karma: +288/-10
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Various issues with ver 1.1.7
« Reply #4 on: April 18, 2021, 08:41:39 AM »
peter_li64, we can upgrade it for you. PM for details.
Please  rate your experience or leave your review
We need your help to build better free open source ecommerce platform for everyone. See how you can help

Offline peter_li64

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Various issues with ver 1.1.7
« Reply #5 on: April 19, 2021, 05:26:57 AM »
@abantecart, I sent you a PM

 

Powered by SMFPacks Social Login Mod