Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: php version abantecart problem  (Read 174 times)

Offline chrisoft

  • Newbie
  • *
  • Posts: 42
  • Karma: +5/-0
    • View Profile
php version abantecart problem
« on: April 25, 2021, 09:37:09 AM »
Hello,
I tried to upgrade to version 1.3.0 and change php version from 7.0 to 7.4. (I tried also 8.0 but abantecart did not run at all) but after upgrade I had issues with product options values.
All option fields real text were missing and showing some unreadable text

example: on color option instead show "green", "red", "blue" it was showing "GT 13G 7144 4GG G 44 4.."

How can I fix this problem?


Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1907
  • Karma: +291/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: php version abantecart problem
« Reply #1 on: April 25, 2021, 03:01:59 PM »
it's not issue related to upgrade
You can check this file https://github.com/abantecart/abantecart-src/blob/master/public_html/install/abantecart_database_upgrade.sql and see.
There no any changes of tables product options etc.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline chrisoft

  • Newbie
  • *
  • Posts: 42
  • Karma: +5/-0
    • View Profile
Re: php version abantecart problem
« Reply #2 on: April 25, 2021, 03:35:36 PM »
Hi, Sorry, I checked the file but I am unable to understand what to do.
I restored a backup to abantecart version 1.2.16, using cPanel.
I am currently at php 7.0 and its working fine, but, if I upgrade any version from php 7.1 and up, the problem exists.
What should I do?

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1641
  • Karma: +470/-4
    • View Profile
Re: php version abantecart problem
« Reply #3 on: April 25, 2021, 04:30:11 PM »
is your cPanel enabled for you to change your php versions using  multiphp manager?   If so ,  then using MultiPHP ini editor , basic mode tab
compare the settings in the 7.0  that is working for you and the 7+ that is not.  Depending on your host the php ini for each version can differ.  You may be able to set your php ini configs within your cPanel or you may need to make the request for your host to do so.

In our many installations we find php 7.3 and 7.4  work correctly if the php ini is set correct.   And our testing shows php 8.0  is working well if 1.3.0 cart version.


Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1907
  • Karma: +291/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: php version abantecart problem
« Reply #4 on: April 26, 2021, 05:46:09 AM »
Hi, Sorry, I checked the file but I am unable to understand what to do.
I restored a backup to abantecart version 1.2.16, using cPanel.
I am currently at php 7.0 and its working fine, but, if I upgrade any version from php 7.1 and up, the problem exists.
What should I do?

You should to check is your new php working in the strict mode. Probably it's a cause.
You can ask your hosting provider support about that.

Fyi: we developed new version 1.3.0 on php8.0 and php7.4. Also we run code on 7.1.
You can try to enable 7.4 and ask hosting provider support.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

 

Powered by SMFPacks Social Login Mod