Author Topic: Following error has occurred during installation  (Read 217 times)

Offline salesn

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
    • View Profile
Following error has occurred during installation
« on: April 04, 2021, 01:43:06 PM »
Hello, I fail to install the latest AbanteCart.


The error that occurs is: "Following error has occurred during installation".


In detail:

"SQL Error: Incorrect table definition; there can be only one TIMESTAMP column with CURRENT_TIMESTAMP in DEFAULT or ON UPDATE clause
Error No: 1293
SQL: CREATE TABLE `abc_email_templates`` `id` int (11) NOT NULL AUTO_INCREMENT,` status` tinyint (1) NOT NULL, `text_id` varchar (255) COLLATE utf8_unicode_ci NOT NULL,` language_id` int (11) NOT NULL , `headers` varchar (255) COLLATE utf8_unicode_ci NOT NULL,` subject` varchar (255) COLLATE utf8_unicode_ci NOT NULL, `html_body` text COLLATE utf8_unicode_ci NOT NULL,` text_body` text COLLATE utf8_unicode_ NULL, `date_added` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,` date_modified` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP, `date_deleted` timestamp NULL DEFAULT NULL,` 0 idary) , UNIQUE KEY `email_templates_text_id_idx` (` text_id`, `language_id`,` store_id`)) ENGINE = MyISAM DEFAULT CHARSET = utf8 COLLATE = utf8_general_ci; PHP call stack: # 0 "


My VPS server configuration: PHP 7.3, MySQL (MariaDB 5.5.68).

Offline salesn

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
    • View Profile
Re: Following error has occurred during installation
« Reply #1 on: April 04, 2021, 02:46:06 PM »
I have to answer for myself ... the problem is solved!  :-[

MySQL base was 5.5.68 done by upgrading to 10.5  ... then the installation of AbanteCart went quickly and without problems.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4899
  • Karma: +255/-2
    • View Profile
Re: Following error has occurred during installation
« Reply #2 on: April 05, 2021, 02:43:19 AM »
Thank you for the update

 

Powered by SMFPacks Social Login Mod