Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: Updated to Abantecart 1.3.0 and Stripe  (Read 220 times)

Offline johnsma2000

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-1
    • View Profile
Updated to Abantecart 1.3.0 and Stripe
« on: May 28, 2021, 05:43:24 PM »
The updates didn't fix the problem. Which is: The transactions are not processing, the orders remain incomplete, I don't receive an email that a transaction or order failed, and it appears that I can't input on Stripe Additional Settings page the Stripe API Key (Which was an entry in the previous Stripe version).

The incomplete transactions have an error at the bottom:
On the map
To view addresses on the interective Google map provide Google API key in the general settings

Is there a way to disable Google maps in Abantecart (I don't trust Google) so I don't need or want to allow Google map provide Google API key?
Where can I get a working version of the Stripe upgrade where I can put in my Stripe provided API Key?

I purchased the Stripe extension without support. It would seem I should have purchased support, too. Unfortunately, there doesn't appear to be a way to purchase it independently from buying and paying again for the extension. So far $39. If I want support too it recharges the original $39 + $11 for support. SO $39 * 2 plus $11. This needs to be clarified. for future users. I thought since I've updated things before that I didn't need additional support, but It appears some things changed in how Stripe and Paypal interact with Abantecart 1.3.0 with the addition of the GOOGLE Crap and I need to know where to put the API Keys from Strip and Paypal and disable Google maps API hassle.

Suggestions would be greatly appreciated.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4899
  • Karma: +255/-2
    • View Profile
Re: Updated to Abantecart 1.3.0 and Stripe
« Reply #1 on: May 31, 2021, 02:23:37 AM »
Hello.
The Google Maps API key settings can be found in the  System → Settings → General
https://abantecart.atlassian.net/wiki/spaces/AD/pages/2056847361/Google+Maps+API+key

Remove the key and save. If you still see the error that means you have something non-standard added to your storefront with non AbanteCart google map. This can be theme, HTML block or 3rd party extension. AbanteCart 1.3 do not have Google Maps in the defaut theme

Offline maxter

  • Full Member
  • ***
  • Posts: 215
  • Karma: +64/-0
    • View Profile
Re: Updated to Abantecart 1.3.0 and Stripe
« Reply #2 on: May 31, 2021, 08:41:55 AM »
Do you have a maps enabled/displayed  on your checkout pages? How was this added? If you use third party extension for google maps, try to disabled it or do what Basara suggested.

Offline johnsma2000

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-1
    • View Profile
Re: Updated to Abantecart 1.3.0 and Stripe
« Reply #3 on: June 02, 2021, 02:38:56 PM »
Hello.
The Google Maps API key settings can be found in the  System → Settings → General

Remove the key and save. If you still see the error that means you have something non-standard added to your storefront with non AbanteCart google map. This can be theme, HTML block or 3rd party extension. AbanteCart 1.3 do not have Google Maps in the default theme

I don't want to use Google Maps if I can somehow turn it off and avoid it. I do not have a Google Maps API and I don't want one.
I do not have an API or Google account listed on the General settings page for Google anything.
I am using the default theme that I started with last year when I first started using Abantecart.

Only after this updating Abantecart from 1.2.16 to 1.3.0 have I seen this error on Incomplete orders.

Also, I keep getting warnings since I updated to 1.3.0 in my messages:
Incorrect config.php file permissions   06/01/2021 14:49   config.php file is writable. It is recommended to set read and execute modes to keep it secured from editing!
Incorrect index.php file permissions     06/01/2021 14:49     index.php file is writable. It is recommended to set read and execute modes for this file to keep it secured and running properly!

Both are set as 0555 but these warnings keep coming back when I delete the warnings. Is 0555 the correct permissions or should I set them to something else?

Stripe is now functioning properly.
Melissa

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4899
  • Karma: +255/-2
    • View Profile
Re: Updated to Abantecart 1.3.0 and Stripe
« Reply #4 on: June 03, 2021, 01:44:23 AM »

Only after this updating Abantecart from 1.2.16 to 1.3.0 have I seen this error on Incomplete orders.


Hello. The Google & Google maps are not related to Stripe payment or problems with the update. You need someone to debug your problem and check your server and AbanteCart error logs

 

Powered by SMFPacks Social Login Mod