Author Topic: EDITED: Links add "com" to URL then 404  (Read 276 times)

Offline unclebacon-live

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
    • View Profile
EDITED: Links add "com" to URL then 404
« on: July 05, 2021, 09:59:06 PM »
Hi,

I run a very small site for a buddy of mine and recently upgraded the cart to 1.3. Since then, when I attempt to login to the admin area, I get redirected from index.php to /com/index.php which then 404's out. I am at a complete loss as for why the URL gets "com" added to it.

I even tried a fresh install and it does the same thing, making me think it's a server/config issue but I didn't change anything before or after the upgrade. The site is also currently in maintenance mode so no telling what would happen if I were to login as a regular customer.

Thanks,

Bacon

Edit 1: So I just wanted to add, it isn't just the admin area, seems to be everywhere. If I go to the main website where it says the maintenance mode message, and click on the logo in the top left, it also adds the /com to the web address. Any suggestions at all?

Edit 2: Well it is working now, but with the /com in the URL...I'm miffed.   ??? ??? I've been on discord with my host for a while and can't find any rewrite rules or whatever. The AbanteCart files are in the base dir of my domain and no "com" folder even exists there.
« Last Edit: July 05, 2021, 11:46:20 PM by unclebacon-live »

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1957
  • Karma: +300/-12
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: EDITED: Links add "com" to URL then 404
« Reply #1 on: July 06, 2021, 03:11:26 AM »
it's a core bug. Already fixed in the developer branch.

To solve just replace file  public_html/core/lib/config.php with this
and then clean cache
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline unclebacon-live

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
    • View Profile
Re: EDITED: Links add "com" to URL then 404
« Reply #2 on: July 06, 2021, 11:20:12 AM »
Boom! Immediate fix. Thank you, I had a peak through github but maybe this was already marked resolved and buried.  ;D

 

Powered by SMFPacks Social Login Mod