Author Topic: issue editing email templates  (Read 2804 times)

Offline BDLG

  • Newbie
  • *
  • Posts: 25
  • Karma: +3/-0
    • View Profile
    • BDL Graphics
issue editing email templates
« on: July 18, 2021, 04:48:22 PM »
I seem to have an issue with editing the email templates. When I click on the icon to edit one, it  takes me out of admin and directly to my website (the url it takes me to is  Prior to my fresh reinstallation, I would see the template and could edit it.

I do not have this issue with editing forms etc. it takes me to the editing screen as it should with everything else.
I cleared cache and tried again. I even tested it with another computer which I have never used before for admin or to go to my website and it does exactly the same thing.
I am using version 1.3.0. with A2 hosting

I am wondering if anyone else has had this issue

This is what I see in my error log:
2021-07-18 16:08:40 - database error: AbanteCart core v.1.3.0 SQL Error: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '' at line 1
Error No: 1064
SQL: SELECT * FROM abj1_email_templates WHERE text_id='admin_approval_email' AND language_id=1 AND store_id=
PHP call stack:
#0 /home/bdlgraph/public_html/core/lib/db.php:102
#1 /home/bdlgraph/public_html/core/engine/extensions.php:1151
#2 /home/bdlgraph/public_html/core/engine/extensions.php:372
#3 /home/bdlgraph/public_html/core/lib/db.php:68
#4 /home/bdlgraph/public_html/admin/model/design/email_template.php:145
#5 /home/bdlgraph/public_html/admin/controller/pages/design/email_templates.php:214
#6 /home/bdlgraph/public_html/admin/controller/pages/design/email_templates.php:184
#7 /home/bdlgraph/public_html/core/engine/dispatcher.php:287
#8 /home/bdlgraph/public_html/core/engine/dispatcher.php:322
#9 /home/bdlgraph/public_html/core/engine/page.php:108
#10 /home/bdlgraph/public_html/core/engine/router.php:193
#11 /home/bdlgraph/public_html/core/engine/router.php:86
#12 /home/bdlgraph/public_html/index.php:97
in <b>/home/bdlgraph/public_html/core/database/amysqli.php</b> on line <b>119</b>
Thanks in advance

EDIT:      I finally ran across another post that had same issue. This worked for me as well :

To solve an issue needs to replace file  public_html/core/lib/config.php
with this
« Last Edit: July 18, 2021, 05:59:11 PM by BDLG »


Powered by SMFPacks Social Login Mod