Author Topic: Critical Twilio error despite disabling extension and Emails not sending  (Read 701 times)

Offline squinn

  • Newbie
  • *
  • Posts: 22
  • Karma: +2/-0
    • View Profile
Thank you in advance.
I briefly enabled twilio just to see what it was about, then I disabled it and set the IM back to default 'no im driver found'message. I know twilio is an SMS service, not email,  but when I do test orders no emails came through to either customer or admin (the order went through ok in the store though), and it came up with an immediate 'critical error' notice, as follows:

Cannot send notification. Communication driver default_twilio is disabled!
Trace: #0 /home/www/domainname/core/lib/im.php on line 335 #1
/home/www/domainname/storefront/model/account/customer.php on line 190 #2 /home/www/domainname/extensions/fast_checkout/storefront/model/extension/fast_checkout.php on line 62 #3 /home/www/domainname/extensions/fast_checkout/storefront/controller/responses/checkout/pay.php on line 1072 #4 /home/www/domainname/extensions/fast_checkout/storefront/controller/responses/checkout/pay.php on line 954


I don't want twilio, so I deleted it entirely but it hasn't stopped the error (also cleared cache).
My mail settings are correct - I just use the default mail (not smtp) and I have a working email address attached to the store. It is not sending the customer email or the admin emails. I do think it's related to that extension, as it calls it the 'default communication'. Even though I disabled it (which should have reversed any changes twilio made) and then went on to delete it after receiving errors, it must have overrode a file somewhere.

 
« Last Edit: April 17, 2022, 07:59:13 PM by squinn »

Offline squinn

  • Newbie
  • *
  • Posts: 22
  • Karma: +2/-0
    • View Profile
OK - so I think I've confirmed that it's related to Twilio.. just tested sending an order update via the status and comments section. It immediately came up with this error, related to twilio and no update was sent to the customer email.

Cannot send notification. Communication driver default_twilio is disabled! Trace: #0 /home/www/domainname/core/lib/im_manager.php on line 322 #1 /home/www/domainname/admin/model/sale/order.php on line 1215 #2 /home/www/domainname/admin/controller/pages/sale/order.php on line 1170 #3 /home/www/domainname/core/engine/dispatcher.php on line 306 #4 /home/www/domainname/core/engine/dispatcher.php on line 341

I can not go live with my site until this is resolved, as the email functionality and updates is critical for this particular business model, so I will be so grateful to have this fixed.
« Last Edit: April 17, 2022, 08:05:22 PM by squinn »

Offline squinn

  • Newbie
  • *
  • Posts: 22
  • Karma: +2/-0
    • View Profile
Ok, so I manually uploaded the Twilio extension folder and reinstalled it, but have it turned off. It gets rid of the critical error, but I'm still not receiving emails from new orders or order page updates, to either the customer or the admin.

Just have mail protocol set to: Mail
no mail parameters
Alert mail: On
No additional alert emails (have tried with and without)



Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5309
  • Karma: +268/-2
    • View Profile
Hello.
You have to install twilio and disable the instant messages in the settings. After that disable twillio extension

Offline squinn

  • Newbie
  • *
  • Posts: 22
  • Karma: +2/-0
    • View Profile
Hello, and Thanks for your reply. I had already followed these steps at the time of my last post.
Attached is a screenshot in case I'm missing something

I have tested mail via storefront orders / contact form / order updates  and no emails are being received by customer or admin still.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5309
  • Karma: +268/-2
    • View Profile
Hello.
Please contact your hosting support and ask why the Mail function is stopped working for you. I think your hosting block emails for some reason

Offline squinn

  • Newbie
  • *
  • Posts: 22
  • Karma: +2/-0
    • View Profile
Thanks for that. I switched to SMTP and all the errors indicated it was, indeed, being blocked by the server. I have contacted them, and they said some outgoing connections were blocked but they've whitelisted it now (however, still neither smtp or default mail working).

May have to find another host at this rate - I have been with these guys for almost ten years now, but the support on my recent issues have not been helpful
I had a time limit with this site, which is almost up, and it would be complete if it wasn't for the mail issue so I'm feeling pretty flat.
Crossing fingers it magically fixes itself like the seo urls did...

Thanks for your help. I want to stick with abantecart because it is way better than oc and wp once it is working.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5309
  • Karma: +268/-2
    • View Profile
Hello.
Thank you for your reply. Can you please tell us what is the hosting company name so other AbanteCart users may find this info helpfull?

 

Powered by SMFPacks Social Login Mod