support

Author Topic: v133 config.php format changes  (Read 3608 times)

Offline yonghan79

  • Jr. Member
  • **
  • Posts: 58
  • Karma: +17/-0
    • View Profile
v133 config.php format changes
« on: May 10, 2023, 08:08:28 AM »
Hi core devs,

I have several questions about the config.php file changes in v1.3.3.

1. v1.3.2 is using define while v1.3.3 is using const? Why is it changed?
2. Is this a permanent change or may change in the future?
3. How do we know that there is changes for the format?

The changes cause us unable to clone updated cart version from prior v1.3.3 to v1.3.3 via Softaculous.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 2051
  • Karma: +320/-13
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: v133 config.php format changes
« Reply #1 on: May 10, 2023, 08:53:01 AM »
Please clarify problem.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline yonghan79

  • Jr. Member
  • **
  • Posts: 58
  • Karma: +17/-0
    • View Profile
Re: v133 config.php format changes
« Reply #2 on: May 10, 2023, 11:02:16 AM »
I tried to clone an updated cart v1.3.3 from v1.3.2 via Softcaulous and it fails.

I check the config.php, compared with a new v1.3.3 install and find out the config.php format are not the same.

v1.3.2 is using define('DB_DRIVER','amysqli');

v1.3.3 is using const DB_DRIVER = 'amysqli';

Also upgrading from v1.3.2 to v1.3.3 does not update the config.php file. This is not using softaculous.

When i change change the define to const, i can clone the website.

My questions are:
1. Why is it changed?
2. Is using const a permanent change or may change in the future?
3. How do we know that there is a change for the config.php format? in case we need to make adjustment again for the clone works.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5847
  • Karma: +275/-2
    • View Profile
Re: v133 config.php format changes
« Reply #3 on: May 11, 2023, 01:27:10 AM »
Hello.
It was changed to match php 8.1 standards
It is a permanent change and you can follow all changes including not yet released in AbanteCart Github https://github.com/abantecart/abantecart-src
« Last Edit: May 11, 2023, 06:46:00 AM by Basara »

 

Powered by SMFPacks Social Login Mod