Author Topic: Abantecart 1.2.16 to 1.3 upgrade error - blank page  (Read 689 times)

Offline egi13946

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Abantecart 1.2.16 to 1.3 upgrade error - blank page
« on: August 19, 2022, 05:13:31 AM »
Hello all

I have a problem when i try to upgrade Abantecart 1.2.16 to 1.3 blank page.

Can someone help please?

Best regards

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5520
  • Karma: +269/-2
    • View Profile
Re: Abantecart 1.2.16 to 1.3 upgrade error - blank page
« Reply #1 on: August 19, 2022, 05:21:03 AM »
Hello.
Check the latest errors in the AbanteCart error log

Offline egi13946

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Abantecart 1.2.16 to 1.3 upgrade error - blank page
« Reply #2 on: August 19, 2022, 06:09:41 AM »
please see attached image

Offline egi13946

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Abantecart 1.2.16 to 1.3 upgrade error - blank page
« Reply #3 on: August 19, 2022, 06:11:42 AM »
2022-08-19 8:39:56 - DEPRECATED: AbanteCart core v.1.2.16 Optional parameter $keys declared before required parameter $key_name is implicitly treated as a required parameter in <b>/home/pg31606/public_html/core/lib/encryption.php</b> on line <b>270</b>
2022-08-19 8:39:56 - warning: AbanteCart core v.1.2.16 Undefined array key "__e" in <b>/home/pg31606/public_html/core/lib/request.php</b> on line <b>54</b>
2022-08-19 8:39:56 - warning: AbanteCart core v.1.2.16 Undefined array key "__e" in <b>/home/pg31606/public_html/core/lib/request.php</b> on line <b>57</b>
2022-08-19 8:39:56 - warning: AbanteCart core v.1.2.16 Undefined array key "settings" in <b>/home/pg31606/public_html/core/lib/cache.php</b> on line <b>299</b>
2022-08-19 8:39:56 - warning: AbanteCart core v.1.2.16 Undefined array key "settings" in <b>/home/pg31606/public_html/core/lib/cache.php</b> on line <b>299</b>
2022-08-19 8:39:56 - warning: AbanteCart core v.1.2.16 Undefined array key "store_id" in <b>/home/pg31606/public_html/core/lib/config.php</b> on line <b>245</b>
2022-08-19 8:39:56 - warning: AbanteCart core v.1.2.16 Attempt to read property "data" on null in <b>/home/pg31606/public_html/core/lib/config.php</b> on line <b>249</b>
2022-08-19 8:39:56 - warning: AbanteCart core v.1.2.16 Trying to access array offset on value of type null in <b>/home/pg31606/public_html/core/lib/config.php</b> on line <b>249</b>
2022-08-19 8:39:56 - warning: AbanteCart core v.1.2.16 Undefined array key "current_store_id" in <b>/home/pg31606/public_html/core/lib/config.php</b> on line <b>257</b>
2022-08-19 8:39:56 - warning: AbanteCart core v.1.2.16 Undefined array key "settings.extension.admin" in <b>/home/pg31606/public_html/core/lib/cache.php</b> on line <b>299</b>
2022-08-19 8:40:03 - DEPRECATED: AbanteCart core v.1.2.16 Optional parameter $keys declared before required parameter $key_name is implicitly treated as a required parameter in <b>/home/pg31606/public_html/core/lib/encryption.php</b> on line <b>270</b>
2022-08-19 8:40:03 - warning: AbanteCart core v.1.2.16 Undefined array key "__e" in <b>/home/pg31606/public_html/core/lib/request.php</b> on line <b>54</b>
2022-08-19 8:40:03 - warning: AbanteCart core v.1.2.16 Undefined array key "__e" in <b>/home/pg31606/public_html/core/lib/request.php</b> on line <b>57</b>
2022-08-19 8:40:03 - warning: AbanteCart core v.1.2.16 Undefined array key "settings" in <b>/home/pg31606/public_html/core/lib/cache.php</b> on line <b>299</b>
2022-08-19 8:40:03 - warning: AbanteCart core v.1.2.16 Undefined array key "settings" in <b>/home/pg31606/public_html/core/lib/cache.php</b> on line <b>299</b>
2022-08-19 8:40:03 - warning: AbanteCart core v.1.2.16 Undefined array key "store_id" in <b>/home/pg31606/public_html/core/lib/config.php</b> on line <b>245</b>
2022-08-19 8:40:03 - warning: AbanteCart core v.1.2.16 Attempt to read property "data" on null in <b>/home/pg31606/public_html/core/lib/config.php</b> on line <b>249</b>
2022-08-19 8:40:03 - warning: AbanteCart core v.1.2.16 Trying to access array offset on value of type null in <b>/home/pg31606/public_html/core/lib/config.php</b> on line <b>249</b>
2022-08-19 8:40:03 - warning: AbanteCart core v.1.2.16 Undefined array key "current_store_id" in <b>/home/pg31606/public_html/core/lib/config.php</b> on line <b>257</b>
2022-08-19 8:40:03 - warning: AbanteCart core v.1.2.16 Undefined array key "settings.extension.admin" in <b>/home/pg31606/public_html/core/lib/cache.php</b> on line <b>299</b>

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5520
  • Karma: +269/-2
    • View Profile
Re: Abantecart 1.2.16 to 1.3 upgrade error - blank page
« Reply #4 on: August 19, 2022, 08:46:32 AM »
Hello.
Looks like you have not upgraded. Errors for 1.2.16
Restore backup and run the manual upgrade https://abantecart.atlassian.net/wiki/spaces/AD/pages/4980799/AbanteCart+Upgrade

Offline egi13946

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Abantecart 1.2.16 to 1.3 upgrade error - blank page
« Reply #5 on: August 19, 2022, 09:57:33 AM »
When i that, blank page appears and have to restore files.

My 1.2.16 must have somethng wrong. Any chance to reinstall core files without damage website?

Best regards

Offline Sam_78

  • Sr. Member
  • ****
  • Posts: 263
  • Karma: +42/-1
    • View Profile
Re: Abantecart 1.2.16 to 1.3 upgrade error - blank page
« Reply #6 on: August 19, 2022, 10:38:47 AM »
Did you backup your site before updating?  if yes, you can restore it

Offline egi13946

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Abantecart 1.2.16 to 1.3 upgrade error - blank page
« Reply #7 on: August 19, 2022, 11:05:02 AM »
Yes, i have a backup of the website while was working fine in version 1.2.16, but when i try to update to 1.3, gets all blank page.

Maybe better  a clean install, or leave it as is.

Best regards

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1765
  • Karma: +511/-7
    • View Profile
Re: Abantecart 1.2.16 to 1.3 upgrade error - blank page
« Reply #8 on: August 19, 2022, 01:43:37 PM »
There are several patch files for the 1.3.0 version -  We have them in our WHY2 information center for easy of finding them.

If you still have your 1.3.0  loaded,  just change out the file and see if it fixes your issues.   If not,  you need to run the updater file again, and then change out the file.

https://why2central.net/patch/abantecart-v1-3-0-default-config-fix/

 

Powered by SMFPacks Social Login Mod