Show Posts


Messages - abolabo

Pages: [1] 2 3 ... 132
1
General Discussion / Re: NIcer Mobile MAin Menu View
« on: January 26, 2022, 05:23:47 AM »

you can turn on mobile view via developer console and see what styles applies.
All that you need you can find in @media section of style.css file

2
Support / Re: Since ~6 month blank page after admin login
« on: January 23, 2022, 11:16:52 AM »
Code: [Select]
Note:
AC version 1.2.13
MySQL version 8.0.22
PHP version (tested) 7.1, 7.2, 7.3 and 7.4 - same result

you have a 1.2.13 version which DO NOT SUPPORT php greater than 5.6.
1.2.16 supports 7.1
1.3.0 supports 8.0

You should to upgrade your abantecart  under php5.6 to version 1.2.16. Then switch to php7.4 and upgrade cart to latest 1.3.2 . In that case you can switch to  php8.0

3
Support / Re: Since ~6 month blank page after admin login
« on: January 23, 2022, 06:20:21 AM »
Looks like your database inner time differ than server time

you can try run query
Code: [Select]
select now();
and  compare it with server time.

Anyway, your issue i not a php-code problem.

If your host have a php mysql-dirver your can switch cart from "pdo" driver to "amysqli" (see system/config.php, DB_DRIVER constant)

4
unfortunately AbanteCart do not have this feature out of box. To solve you should to create your own hook to regulate language based on domain

5

Currently using version1.3.1

please try to replace file core/lib/mail.php with file from 1.3.2 version

6
Extension Support / Re: How do I fix 403 error in text banner manager?
« on: December 27, 2021, 04:01:11 PM »
looks like you have a permission issue with "extensions" directory.
Can you post errors from error.log file?

7
to solve you should to write a hooks for form and validation.
Changing of core code not recommended. These changes will be overridden by future upgrade process.
You can clone your current template via our developer tools extension and add hooks for form there.

8
Support / Re: paypal and razorpay storefront api
« on: December 24, 2021, 06:13:49 AM »
Our API looking for "api" method of payment extension. Only two "default" payment extensions have a "api()" method inside their response controller. COD and Authorize.Net. Just open file  and check. 
If you wish to develop this method for default paypal etc you are welcome. We like any contributions:-)

9
you should to solve an issue with css rules for mobile @media section.

10
Support / Re: Stripe not receiving OrderID
« on: December 23, 2021, 06:10:59 AM »
Hi,

Thanks for the tip. I've not really used Stripe at all before but after gaining access and checking their logs it appears that everything is coming through fine.

It's just the way the info is displayed in Balances/Payouts/Transactions description area now doesn't include the OrderID.
Previously all the descriptions were the same format, (shop name, order id, customer name), now it just has the customer name. This is needed for ease of doing the balance reports.

Is this due to us updating Abantecart and the Stripe module or is it something Stripe themselves have changed? How is this description line populated?

Many thanks for your time.

(Edit)
I notice in the logs that the orderID appears in the "statement_descriptor" but "description" it is set null.
On the Stripe API example of the payout object, the statement_descriptor is null but description is filled in.
Is this relevant? Also where in Abantecart is this info set?

Cheers

https://github.com/abantecart/abantecart-src/blob/master/public_html/extensions/default_stripe/storefront/controller/responses/extension/default_stripe.php#L153

If you will be improve a code please send us your modifications (you can do this via github pull request.. or post here)

Let's make a code better together;-)

11
Support / Re: Stripe not receiving OrderID
« on: December 22, 2021, 03:07:05 AM »
Hi,

We recently updated to 1.3.0 and then got the Stripe issue of it not capturing payments. So we updated default_stripe to 1.0.5 which helped with the capture issue.

Since then, however, we are no longer receiving OrderID's in Stripe.

Previously the description would say "Shop Name Order #xxxx - Customer Name"
but now just says "Guest Customer: Customer Name" or "Customer ID: xxxx" without any reference to the OrderID.

Could you please help as it's causing a few issues for us.

Many thanks

hi.
Did you see requests from your cart to stripe API in the logs of  "Developers" section ?

12
General Support / Re: When Doing A Manual Upgrade to 1.3.2
« on: December 21, 2021, 09:16:53 AM »
Hi

Okay cool

I see that the version.php is not actually present in the https://github.com/abantecart/abantecart-src/releases/download/1.3.2/abantecart_1.3.2_upgrade_only.tar.gz archive, this is what I am currently using to do my manual upgrade

this file can be absent in the package.
You need to recheck file permissions for it. To see changes it must be writable for web-server user

13
General Support / Re: Issues with SNI, hostname and cart
« on: December 21, 2021, 04:34:19 AM »
Did you ever find the issue? I am facing something similar. The site mostly will function as expecting but at times will result back to the IP address for resources (css and image files) and I have been seeing also some issues with featured product block even grabbing the SMTP setting Domain entry. Clearing cache will resolve the issue but then it appears to reset randomly after a few hours/days. .htaccess and URL entries are good in the settings page.

Some web-spider do this. You should block access by IP address.
Just add redirect from ip to domain name.

14
Embedding / Re: Unable to get modal windows to open
« on: December 06, 2021, 04:41:54 AM »
i guess you have a broken hrefs for elements on your html-page. Some of then loaded from cdn, other by relative link.. I think issue in relative link and <base> tag
You can try this instead to make it work,

Code: [Select]
<!DOCTYPE html>
<html lang="en">
<head>
<!-- Required meta tags -->
<meta charset="utf-8">
<base href="https://bridgesofloveshow.com/store/">
</head>
<body>
<script src="https://bridgesofloveshow.com/store/index.php?rt=r/embed/js" type="text/javascript"></script>
<div style="display:none;" class="abantecart-widget-container" data-url="https://bridgesofloveshow.com/store/" data-css-url="https://bridgesofloveshow.com/store/storefront/view/default/stylesheet/embed.css" data-language="en" data-currency="USD">
   <div id="abc_534" class="abantecart_product" data-product-id="1" data-language="en" data-currency="USD">
      <div class="abantecart_image"></div>
      <h3 class="abantecart_name"></h3>
      <div class="abantecart_price"></div>
      <div class="abantecart_quantity"></div>
      <div class="abantecart_addtocart"></div>
   </div>
</div>
</body>
</html>

15
Built-in Features / Re: Sending SMTP via Office365..?
« on: November 12, 2021, 09:49:02 AM »
This is for anyone who is using GoDaddy and 365 office email for SMPT mail setup.
You need to set the mail up with LOCALHOST as the SMTP host and provide the username which will be the office 365 email you set up through GoDaddy. For the PORT you need to put 25.

Note: you DONT need a password

Here is their documentation: ae.godaddy.com/help/send-form-mail-using-an-smtp-relay-server-953

In theory you should add your abantecart into whitelist of applications first

https://docs.microsoft.com/uk-ua/Exchange/mail-flow-best-practices/how-to-set-up-a-multifunction-device-or-application-to-send-email-using-microsoft-365-or-office-365?redirectSourcePath=%252fen-us%252farticle%252fHow-to-set-up-a-multifunction-device-or-application-to-send-email-using-Office-365-69f58e99-c550-4274-ad18-c805d654b4c4

Pages: [1] 2 3 ... 132

Powered by SMFPacks Social Login Mod