Show Posts


Messages - squinn

Pages: [1]
1
Hi - I have my store set to hide items once they are sold, as I'm selling individual/unique products.

When someone clicks on a link that goes to a sold/hidden product it currently says 'product not found'

I'd like to change that text to mention product has been sold, and link to my home page.  I have tried storefront>language>product>product.xml  where I found text 'product not found' but despite clearing cache no changes are showing. Not sure this is the right spot, and have searched other language pages but can't find any where else with that text.

Any ideas?

Thank you all.

2
Customization help / Detect country/geolocation
« on: November 30, 2020, 07:04:44 PM »
I can't find anywhere this can be done. I have my store based in Australia, but I intend to have a domain for the US and the UK (.com and .co.uk respectively). As these will each have their own base currency, multistore doesn't suit (according to abantecart changing the base currency converts it in every store). So I would like each site to detect the geolocation of the user, and if they are not in that store's country, they will then have the choice to stay or go to the site that is dedicated to their own country, via a pop up with linked url.
Has anybody managed to do this, or is there an extension I've missed that is compatible with abantecart?
Thanks in advance.

3
Thank you so much for your reply.  No recent errors in error log oddly. Everything else seems fine. The problem is intermittent, but persistent once it starts (made my work impossible all morning).  However, I logged in a few hours later and continued with no issues. If I manage to figure it out, I'll post results here in case it helps others... starting to suspect an issue with my host.

4
How-to questions / Re: Help please!
« on: July 30, 2019, 10:38:30 PM »
It really appears to be triggered by 'saving' anything new on the product line (options, media, relations, promotions,)


5
Initially when I installed abantecart - newest version - everything has worked really well and I was able to quickly add and edit products without an issue.
Until it started randomly throwing an error every time I edited a section of a new or existing product. 

The error is: Cannot establish database connection. Check your database connection settings. in /home1/mysitename/public_html/core/database/amysqli.php on line 54

Initially the error only showed on admin side, but now it causes the front end to temporarily disconnect to. It usually comes back live after a few minutes, with or without cookie/cache clearing.

I honestly can not find any reason - I haven't changed any core files nor done any updates since installing this year.  I can't even load the admin login page after I do it for a while.

The only thing I can think is the timeout in that section of amysql is 60seconds, but it isn't anywhere close to 60 seconds when it throws the error.

Terrible timing, as I have an existing customer base from another project I was just introducing this site to today and tomorrow and now I can't do a few tweaks I really wanted to do, as it keeps taking the whole site offline (so unprofessional).  Another issue, that may or may not be connected - sometimes the admin security time out is very short and I have to re-login every few minutes. No error, just logs me out.

Or there's a possible conflict with new paid extensions (bought from abantecart official marketplace)? Does this happen? They are meant to be compatible with my version of abantecart. 

Any advice would be so appreciated.




6
From the admin side...

It would be helpful for design purposes. 

Sometimes I'd like to have something on the left hand column on desktop, but I don't want mobile or tablet users to have to scroll through it before getting to the main content.
There's such a disparity in display between a wide screen desktop set up and a mobile device.

As an aside, I think the title for the block (that shows in the front end) shouldn't be required by default, not every bit of html needs a title.




7
Templates / Re: Main menu - Mobile View
« on: June 12, 2019, 11:01:35 PM »
Thanks so much for your reply :D  I hadn't thought of that and it should solve it.  I'll give it a go in a while  :)

8
Templates / Main menu - Mobile View
« on: June 11, 2019, 11:13:08 PM »
I only require the main menu (the top one: account | cart | checkout) on desktop view. 

The responsive view brings it down to a drop down 'main menu' and further scaling down gives the classic hamburger view - but I do not need either of these.
 The category menu is also responsive and has 'Go to..' which allows access to account | cart |checkout, making the responsive main menu superfluous (except on desktop.)

I have tried deleting code in custom.js / header.tpl based on an answer to a similar question posed in 2016.  The code had changed a bit, but it was still fairly obvious which bits related to the menu.  However, it didn't remove the menu from mobile view unfortunately, nor seem to affect it in any way. 

Any help would be greatly appreciated.

Pages: [1]

Powered by SMFPacks Social Login Mod