Show Posts


Messages - abolabo

Pages: [1] 2 3 ... 131
1
Embedding / Re: Unable to get modal windows to open
« on: December 06, 2021, 04:41:54 AM »
i guess you have a broken hrefs for elements on your html-page. Some of then loaded from cdn, other by relative link.. I think issue in relative link and <base> tag
You can try this instead to make it work,

Code: [Select]
<!DOCTYPE html>
<html lang="en">
<head>
<!-- Required meta tags -->
<meta charset="utf-8">
<base href="https://bridgesofloveshow.com/store/">
</head>
<body>
<script src="https://bridgesofloveshow.com/store/index.php?rt=r/embed/js" type="text/javascript"></script>
<div style="display:none;" class="abantecart-widget-container" data-url="https://bridgesofloveshow.com/store/" data-css-url="https://bridgesofloveshow.com/store/storefront/view/default/stylesheet/embed.css" data-language="en" data-currency="USD">
   <div id="abc_534" class="abantecart_product" data-product-id="1" data-language="en" data-currency="USD">
      <div class="abantecart_image"></div>
      <h3 class="abantecart_name"></h3>
      <div class="abantecart_price"></div>
      <div class="abantecart_quantity"></div>
      <div class="abantecart_addtocart"></div>
   </div>
</div>
</body>
</html>

2
Built-in Features / Re: Sending SMTP via Office365..?
« on: November 12, 2021, 09:49:02 AM »
This is for anyone who is using GoDaddy and 365 office email for SMPT mail setup.
You need to set the mail up with LOCALHOST as the SMTP host and provide the username which will be the office 365 email you set up through GoDaddy. For the PORT you need to put 25.

Note: you DONT need a password

Here is their documentation: ae.godaddy.com/help/send-form-mail-using-an-smtp-relay-server-953

In theory you should add your abantecart into whitelist of applications first

https://docs.microsoft.com/uk-ua/Exchange/mail-flow-best-practices/how-to-set-up-a-multifunction-device-or-application-to-send-email-using-microsoft-365-or-office-365?redirectSourcePath=%252fen-us%252farticle%252fHow-to-set-up-a-multifunction-device-or-application-to-send-email-using-Office-365-69f58e99-c550-4274-ad18-c805d654b4c4

3
General Support / Re: Abantecart V 1.3.1 on multistore
« on: November 09, 2021, 04:36:36 AM »
is your category assigned to second store? do you see second store in the store list on category edit form page?

4
General Support / Re: Validate Zip code
« on: November 08, 2021, 10:10:29 AM »
Hi Abolabo, how do I call this function? Can I just use this function instead  public function validateRegistrationData( $data ) {

and add the lines

 if(mb_strlen($that->request->post['postcode'])>5){
     $that->error['postcode] = 'Your error text here';
   }


Because I see validation in this function that are already being used like:

if ((mb_strlen($data['city']) < 3) || (mb_strlen($data['city']) > 128)) {
         $this->error['city'] = $this->language->get('error_city');
      }

Yes you can, but future upgrades will overwrite it.
Best way is to create your own extension (for example clone current template as extension via our developer_tools) and put validation into the hook-file as i posted above.

5
General Support / Re: Validate Zip code
« on: November 08, 2021, 03:16:18 AM »
you can try to add hook

public function onModelAccountCustomer_ValidateData(){
    $that = $this->baseObject;
    //do check
    if(mb_strlen($that->request->post['postcode'])>5){
     $that->error['postcode] = 'Your error text here';
   }

}

See $this->extensions->hk_ValidateData($this, [__FUNCTION__]);  call inside model/account/customer for details.
Also you should add the same hook for guests

6
Support / Re: paypal and razorpay storefront api
« on: November 08, 2021, 03:06:05 AM »
please clarify your question.

7
Installation and Configuration / Re: Update to 1.30
« on: October 22, 2021, 06:23:44 AM »
Thank you. Here is the latest log:

2021-10-22 8:42:58 - load error:  AbanteCart core v.1.2.16 Error: no languages available in AbanteCart !
Trace:
   #0 /home/mainevoy/public_html/core/engine/language.php on line 93
   #1 /home/mainevoy/public_html/core/lib/language_manager.php on line 39
   #2 /home/mainevoy/public_html/core/init.php on line 485
   #3 /home/mainevoy/public_html/index.php on line 55

2021-10-22 8:42:58 - load error:  AbanteCart core v.1.2.16 Error: Can not Load any language! in <b>/home/mainevoy/public_html/core/engine/language.php</b> on line <b>95</b>
2021-10-22 8:44:11 - App Warning:  AbanteCart core v.1.2.16 cardknox directory is missing in /home/mainevoy/public_html/core/engine/extensions.php on line 325
2021-10-22 8:44:43 - App Warning:  AbanteCart core v.1.2.16 cardknox directory is missing in /home/mainevoy/public_html/core/engine/extensions.php on line 325
2021-10-22 8:45:13 - App Warning:  AbanteCart core v.1.2.16 cardknox directory is missing in /home/mainevoy/public_html/core/engine/extensions.php on line 325
2021-10-22 8:45:32 - App Warning:  AbanteCart core v.1.2.16 cardknox directory is missing in /home/mainevoy/public_html/core/engine/extensions.php on line 325

hm.. why log writes your version is 1.2.16? not 1.3.0?

What php version do you use?

You can try to rollback to last backup and run upgrade via file upload (see Menu Extensions->Install Extensions see tab Extension Upload)

8
Installation and Configuration / Re: Update to 1.30
« on: October 22, 2021, 05:19:54 AM »
Thank you. Here is the latest log:

2021-10-22 8:42:58 - load error:  AbanteCart core v.1.2.16 Error: no languages available in AbanteCart !
Trace:
   #0 /home/mainevoy/public_html/core/engine/language.php on line 93
   #1 /home/mainevoy/public_html/core/lib/language_manager.php on line 39
   #2 /home/mainevoy/public_html/core/init.php on line 485
   #3 /home/mainevoy/public_html/index.php on line 55

2021-10-22 8:42:58 - load error:  AbanteCart core v.1.2.16 Error: Can not Load any language! in <b>/home/mainevoy/public_html/core/engine/language.php</b> on line <b>95</b>
2021-10-22 8:44:11 - App Warning:  AbanteCart core v.1.2.16 cardknox directory is missing in /home/mainevoy/public_html/core/engine/extensions.php on line 325
2021-10-22 8:44:43 - App Warning:  AbanteCart core v.1.2.16 cardknox directory is missing in /home/mainevoy/public_html/core/engine/extensions.php on line 325
2021-10-22 8:45:13 - App Warning:  AbanteCart core v.1.2.16 cardknox directory is missing in /home/mainevoy/public_html/core/engine/extensions.php on line 325
2021-10-22 8:45:32 - App Warning:  AbanteCart core v.1.2.16 cardknox directory is missing in /home/mainevoy/public_html/core/engine/extensions.php on line 325

Is your database table `languages` contains some rows? You can check it via phpMyAdmin.
Also you should to check status column value

9
Built-in Features / Re: How to allow customer download tar.gz file?
« on: October 18, 2021, 05:52:42 AM »
Are there any way so when customer download the file, it will automatically downloaded as tar.gz file instead of having to manually rename the file name.

it's already works so. Did you checked?

10
Built-in Features / Re: How to allow customer download tar.gz file?
« on: October 18, 2021, 04:59:29 AM »
hi.
This is not a problem. If you click download icon browser propose to save file with .tar.gz file extension.

File on disk have our inner file naming. Please ignore it.

11
General Support / Re: Logo and Links URL
« on: October 15, 2021, 03:26:37 AM »
Hello abolabo,

So I tried to upgrade from 1.3.0 to 1.3.1 and I got the following error:

"7.3.0+ Required for AbanteCart to work properly! Please contact your system administrator or host service provider."


Even though php7.4 is set on server.

Are you sure? You can check it via admin menu->System->Settings->system and click on phpInfo() button at the heading.


12
General Support / Re: Logo and Links URL
« on: October 13, 2021, 02:17:59 AM »
To solve issue please upgrade app up to latest version 1.3.1

13
I have deleted the file but I still get an error.

[12-Oct-2021 12:51:25 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/BasePaymentHandler.php on line 57

Delete this lib too. And line in the init.php file where it requires

14
[12-Oct-2021 11:20:20 UTC] PHP Fatal error:  require_once(): Failed opening required '/home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/sewnsails/public_html/AbanteCart/core/init.php on line 276

just open this file and delete this line (276).
Then we recommend you to upgrade your AbanteCart up to latest version

15
I attempted upgrade this morning 10/11. Server error log shows these errors, all from previous days.

[Mon Sep 06 19:04:04.039003 2021] [access_compat:error] [pid 3345:tid 47787809580800] [client 193.19.109.58:28203] AH01797: client denied by server configuration: /home/sewnsails/public_html/AbanteCart/admin/customers.php
[Mon Sep 06 15:43:06.606391 2021] [access_compat:error] [pid 22662:tid 47787817985792] [client 193.19.109.58:13481] AH01797: client denied by server configuration: /home/sewnsails/public_html/AbanteCart/admin/customers.php
[Mon Sep 06 15:14:02.646683 2021] [access_compat:error] [pid 25308:tid 47787807479552] [client 193.19.109.58:23691] AH01797: client denied by server configuration: /home/sewnsails/public_html/AbanteCart/admin/customers.php
[Sat Sep 04 08:42:10.615654 2021] [access_compat:error] [pid 8876:tid 47787907520256] [client 154.6.20.126:13947] AH01797: client denied by server configuration: /home/sewnsails/public_html/AbanteCart/admin/customers.php     

AbanteCart Error log for 10/11 is:

[11-Oct-2021 12:27:25 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 12:27:45 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 12:28:42 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 12:28:46 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 12:29:01 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 12:29:09 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 12:32:24 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 12:32:49 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 12:33:43 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 12:37:32 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 12:45:34 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 13:13:51 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 13:15:19 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 13:21:48 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 13:58:02 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 13:58:08 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 13:58:21 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 14:40:01 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 14:46:30 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 14:46:51 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 14:46:57 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22
[11-Oct-2021 14:55:07 UTC] PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php on line 22

Your should try to delete file /home/sewnsails/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php It's not needed anymore from version 1.3.0.

Pages: [1] 2 3 ... 131

Powered by SMFPacks Social Login Mod