Author Topic: Need help with upgrade  (Read 9342 times)

Offline sewkitty

  • Newbie
  • *
  • Posts: 45
  • Karma: +2/-0
    • View Profile
Need help with upgrade
« on: March 09, 2016, 09:58:58 AM »
Is there someone who I can hire to help me with a cart upgrade? I had a clone site created & have had so many issues with the update it is crazy. My support at my host has been amazing but there is only so much they can do. I did the update on the clone site & no images or downloads would work. I could not even add any it came up with a resource folder error. We changed permissions on all the folders and it never would work. So we recloned the site thinking maybe that was an issue. Then I updated again & the whole thing went down with the long error of:

warning: require_once(/home/stitchi7/public_html/dev/core/engine/task.php) [function.require-once]: failed to open stream: No such file or directory in /home/stitchi7/public_html/dev/core/init.php on line 191
Fatal error: require_once() [function.require]: Failed opening required '/home/stitchi7/public_html/dev/core/engine/task.php' (include_path='.:/usr/local/php53/pear') in /home/stitchi7/public_html/dev/core/init.php on line 191
compile error: require_once() [function.require]: Failed opening required '/home/stitchi7/public_html/dev/core/engine/task.php' (include_path='.:/usr/local/php53/pear') in /home/stitchi7/public_html/dev/core/init.php on line 191

That support finally fixed it but have told me this morning that they cannot help anymore as this issue is on the cart side & not the server side.

Any help I can get I would greatly appreciated.
Thanks
Elizabeth

Offline webdevmerc

  • Full Member
  • ***
  • Posts: 172
  • Karma: +32/-1
    • View Profile
Re: Need help with upgrade
« Reply #1 on: March 09, 2016, 06:05:00 PM »
What version are you upgrading from and to?  You need to upgrade every . point release and can't skip versions.

Please note that if you cloned your site, you will need to make sure all the live images are also cloned (copied) in the clone directory/folder setup.


I have not had luck using the auto-upgrade for whatever reason.

If you need to upgrade multiple times and versions, it maybe easier to just start from the current version and try to rebuild the new version site to be like the old site.

Offline sewkitty

  • Newbie
  • *
  • Posts: 45
  • Karma: +2/-0
    • View Profile
Re: Need help with upgrade
« Reply #2 on: March 09, 2016, 10:29:29 PM »
o.k. that makes a LOT of sense. I am using 1.1.9 right now.
Where do I find all the updates that are in-between?
If you did not get the auto-upgrade to work, how did you upgrade?

Not sure what you mean by

it maybe easier to just start from the current version and try to rebuild the new version site to be like the old site.

Thanks so much!

Offline webdevmerc

  • Full Member
  • ***
  • Posts: 172
  • Karma: +32/-1
    • View Profile
Re: Need help with upgrade
« Reply #3 on: March 10, 2016, 09:37:40 AM »
o.k. that makes a LOT of sense. I am using 1.1.9 right now.
Where do I find all the updates that are in-between?
If you did not get the auto-upgrade to work, how did you upgrade?

Not sure what you mean by

it maybe easier to just start from the current version and try to rebuild the new version site to be like the old site.

Thanks so much!


Here's the manual upgrade docs:
http://docs.abantecart.com/pages/upgrade/manual.html

You can get all the . point packages here (same as listed in the docs page above):
https://drive.google.com/folderview?id=0B64_ELUMJQjJfms3U2Y5WDZycmQ2bXFkY2JxNmY1Qkp6QmpNUGo2ck5UYWF0ek44bnBiNVE&usp=drive_web#list

The upgrade, from what I have read 1.1.9 to 1.2 was a large jump so doing that one will be your biggest challenge since there is a high chance that things will just not work.  Even updating from 1.2.3 to 1.2.4 broke stuff for me since I made changes to core files and had to put some changes back in afterwards.

I always suggest doing testing/upgrades on a test site first since you WILL run into issues (for me at least, there were always problems).

If your site is completely stock, the upgrades should be pretty straight forward, but most sites aren't stock I don't think AND, the place you are hosting at probably will break stuff just regularly due to their own security changes, updates, etc...


When the auto-update didn't work for me for whatever reason (maybe my mysql table names are off, my hosting provider changes stuff, who knows), I followed the guide above and did the manual upgrade.  I am now (moving forward) only planning to do the manual upgrade since the auto hasn't worked consistently for me and I generally like to know what's going on anyways in case things break and I need to fix stuff (as you notice, using an open source platform keeps cost down, but you're sorta on your own...I have worked in the past as a linux/unix sysadmin, but have held roles in many aspects of IT from erp apps development, database, networking, etc...so don't mind the problems too much).

All that said, the manual update does miss things I've noticed so your version number will be off in the system (it doesn't update) as well as the upgrade package script not running so you need to run those in a certain order.


My comment on using the current version and try to rebuild means instead of even upgrading, just load the latest version and use/live with that.  Export and re-import all your data (need data cleaning which is a total chore) and try to make the new version look and work like your old site.  If you made a lot of customizations, have paid extensions, etc etc etc, those may not work anymore at all since they are usually tied to a version.



Offline sewkitty

  • Newbie
  • *
  • Posts: 45
  • Karma: +2/-0
    • View Profile
Re: Need help with upgrade
« Reply #4 on: March 10, 2016, 10:29:45 AM »
Thank you so much. At this point I don't think I will be upgrading. I don't feel I have the knowledge or ability to pull this off & really do not have the time to try & figure it out either. LOL
I already spent a week on this & accomplished nothing. I will try & do what I can with the version I have.
Thanks again for the info :-)

Offline sewkitty

  • Newbie
  • *
  • Posts: 45
  • Karma: +2/-0
    • View Profile
Re: Need help with upgrade
« Reply #5 on: March 10, 2016, 11:35:31 AM »
I decided to try the next upgrade in line 1.2.0 on my cloned site.
It seemed to upgrade fine but when I add a new product I cannot add any images to it or zip files.
I get the error  (error_Please check 'resources' folder permissions.)
I have upgraded EVERY file I can find (including all subfiles) to 0777 in resources & images. It still will not allow
me to add an image or a zip file to my product. Any idea what I am missing?
Thank you!
Elizabeth

Offline webdevmerc

  • Full Member
  • ***
  • Posts: 172
  • Karma: +32/-1
    • View Profile
Re: Need help with upgrade
« Reply #6 on: March 10, 2016, 01:44:51 PM »
I decided to try the next upgrade in line 1.2.0 on my cloned site.
It seemed to upgrade fine but when I add a new product I cannot add any images to it or zip files.
I get the error  (error_Please check 'resources' folder permissions.)
I have upgraded EVERY file I can find (including all subfiles) to 0777 in resources & images. It still will not allow
me to add an image or a zip file to my product. Any idea what I am missing?
Thank you!
Elizabeth

If the auto-update went fine, then you're probably half way there already.  Also, with Abantecart, you HAVE to apply each update individually so to go from 1.1.9 to 1.2.5,  you need to do 1.2.0 first anyways, then 1.2.1, 1.2.2...etc...


Maybe change the resources folder to 777 also?


I agree with you that you should consider and think about upgrading eventually sometime in the future since 1.1.9 is 2 years old now(?) and I'd only assume there are security fixes as well as the idea that most people would probably recommend you upgrade anyways if you ran into any problems in the future.  I also doubt anyone is developing any extensions for older versions due to limited use and general obsolescence right out the gate.


See if the permissions on the folder fixes it...

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1798
  • Karma: +520/-7
    • View Profile
Re: Need help with upgrade
« Reply #7 on: March 10, 2016, 03:28:37 PM »
http://docs.abantecart.com/pages/install/options/regular_installation.html

here's the permissions that the docs suggest -  and it has worked well for me on all my installs.


Offline sewkitty

  • Newbie
  • *
  • Posts: 45
  • Karma: +2/-0
    • View Profile
Re: Need help with upgrade
« Reply #8 on: March 10, 2016, 04:51:17 PM »
I have changed all the files I am suppose to 0777 & it still does not work. This is beyond frustrating. I did go from 1.1.9 to 1.2.0
I have not updated any further than that at this point. Do you think updating to the next versions would help any?

Offline webdevmerc

  • Full Member
  • ***
  • Posts: 172
  • Karma: +32/-1
    • View Profile
Re: Need help with upgrade
« Reply #9 on: March 11, 2016, 07:05:03 PM »
I have changed all the files I am suppose to 0777 & it still does not work. This is beyond frustrating. I did go from 1.1.9 to 1.2.0
I have not updated any further than that at this point. Do you think updating to the next versions would help any?


I highly doubt upgrading further would help since whatever is wrong would translate to future versions and may lead to other problems down the line.  Did you try the auto-update or manual?


I don't know if the developers help with upgrades, but you might want to check with them to see if they take fees to help (I have seen them do paid custom work for some folks)...and if not, I am open to trying, but I am not setup currently for that, but could setup something on elance or something or discuss something via personal message.

Doing upgrade/update work has been something I've considered for a little while anyways.

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1798
  • Karma: +520/-7
    • View Profile
Re: Need help with upgrade
« Reply #10 on: March 12, 2016, 04:28:41 PM »
Hey, hey SewKitty,
Tried to PM you,  but seems you've not checked your My Messages in the forum?! 

Quote
PM could not be sent to 'sewkitty' as their inbox is full!

Want to converse with you off forum about your issue but..... no can do with a full inbox.

Lee

Offline sewkitty

  • Newbie
  • *
  • Posts: 45
  • Karma: +2/-0
    • View Profile
Re: Need help with upgrade
« Reply #11 on: June 08, 2016, 04:06:23 PM »
Sorry Lee, I have emptied my in box now.

 

Powered by SMFPacks Social Login Mod