Author Topic: Incorrect index.php file permissions  (Read 9262 times)

Offline animetoys

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Incorrect index.php file permissions
« on: June 15, 2016, 10:23:33 PM »
Hi I could solve this problem.

home/hjpnlklb/public_html/index.php file is writable. It is recommended to set read and execute modes for this file to keep it secured and running properly!

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5855
  • Karma: +275/-2
    • View Profile
Re: Incorrect index.php file permissions
« Reply #1 on: June 16, 2016, 01:09:36 AM »
Hi.

You need to change index.php file permission in order to be more secure.
This is very easy to fix. Go to your site root (where AbanteCart files installed) via FTP or hosting Cpanel Filemanger and change file permission to 444 or 644
Read more http://docs.abantecart.com/pages/tips/troubleshooting.html#permissions

Offline timlight10

  • Full Member
  • ***
  • Posts: 124
  • Karma: +15/-1
    • View Profile
    • Dedicated Presentation Solutions
Re: Incorrect index.php file permissions
« Reply #2 on: February 26, 2023, 04:00:49 PM »
After upgrading from version 1.2.16 to 1.3.3, I am getting this error message all the time. My index.php file is already set to 644, but I still get the error. How do I stop it from happening?

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5855
  • Karma: +275/-2
    • View Profile
Re: Incorrect index.php file permissions
« Reply #3 on: February 27, 2023, 01:49:11 AM »
Hello.
This file should be set with 644 or 640 permissions (444, or 400 depending on your server setup).

Offline timlight10

  • Full Member
  • ***
  • Posts: 124
  • Karma: +15/-1
    • View Profile
    • Dedicated Presentation Solutions
Re: Incorrect index.php file permissions
« Reply #4 on: February 28, 2023, 09:43:21 AM »
My index.php file is already set to 644, but I still get the error. How do I stop it from happening?

Offline timlight10

  • Full Member
  • ***
  • Posts: 124
  • Karma: +15/-1
    • View Profile
    • Dedicated Presentation Solutions
Re: Incorrect index.php file permissions
« Reply #5 on: March 04, 2023, 09:39:33 AM »
I'd like to get this error message to go away. Why am I still seeing it if my file has the correct permissions?

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5855
  • Karma: +275/-2
    • View Profile
Re: Incorrect index.php file permissions
« Reply #6 on: March 06, 2023, 01:08:28 AM »
Hello.
You see this because the file is writable but it should not be. Please set more strict permissions (may wary on different hostings/servers)

Offline timlight10

  • Full Member
  • ***
  • Posts: 124
  • Karma: +15/-1
    • View Profile
    • Dedicated Presentation Solutions
Re: Incorrect index.php file permissions
« Reply #7 on: March 26, 2023, 09:30:34 AM »
I "resolved" this by setting Settings > System > System Check to Disabled. Not really a resolution, but since the file permissions are correct and AbanteCart was unable to provide further support, at least I am not nagged with the error message constantly.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5855
  • Karma: +275/-2
    • View Profile
Re: Incorrect index.php file permissions
« Reply #8 on: March 27, 2023, 02:12:45 AM »
I "resolved" this by setting Settings > System > System Check to Disabled. Not really a resolution, but since the file permissions are correct and AbanteCart was unable to provide further support, at least I am not nagged with the error message constantly.

Hello. AbanteCart checks if files are writable and return an error even if "correct" permissions are set. Not all servers are configured correctly or in the same way. I suggest setting more strict permissions if 644 is left files writable.


 

Powered by SMFPacks Social Login Mod