Author Topic: Issue with 1.04 - site corrupts for some reason - Demo site too!  (Read 2865 times)

Offline mrchrisbarnes

  • Newbie
  • *
  • Posts: 8
  • Karma: +2/-0
    • View Profile
Issue with 1.04 - site corrupts for some reason - Demo site too!
« on: September 11, 2012, 07:05:53 AM »
1.04 seems to have some sort of issue where after a while the site will not load & you get the message - There has been an error processing your request!
Please see attached image, you even get this on the demo site as well as my own site? Any ideas?

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4150
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Issue with 1.04 - site corrupts for some reason - Demo site too!
« Reply #1 on: September 11, 2012, 08:08:54 AM »
Can you give us an idea what page and task you performed when you noticed this happening?
It is possible happening due to server slow performance at the time or database access issues.
Please check the log file right after this happens and report what you see in the log.

You can locate log in admin -> system -> logs -> error log
or you can access log file on your server in /system/logs/error.txt
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4150
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Issue with 1.04 - site corrupts for some reason - Demo site too!
« Reply #2 on: September 11, 2012, 10:12:49 AM »
One more thing you can try.
Increase PHP memory limit.
This is located in php.ini file

Change:
memory_limit = 64M;
TO:
memory_limit = 128M;
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1773
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Issue with 1.04 - site corrupts for some reason - Demo site too!
« Reply #3 on: September 16, 2012, 05:50:00 PM »
check is apc php installed. try to disable it.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline mrchrisbarnes

  • Newbie
  • *
  • Posts: 8
  • Karma: +2/-0
    • View Profile
Re: Issue with 1.04 - site corrupts for some reason - Demo site too!
« Reply #4 on: September 18, 2012, 12:07:43 PM »
Hi thanks for replies. The issue appears to happen on certain browsers at various times. for example I do not get the error on some computers but do on others. All browsers seem to have the same issue at sometime or other. At the moment I cant view the demo site or my own site on my one computer but can on some others. Every so often the problem clears itself on one computer but then you cant view site on other computers / browsers. Not sure what causes the database error but every time you get the error on the site the following gets logged in the error file:
2012-09-18 15:50:15 - database error:  Error: Duplicate entry '0-index_home-0-heading_title' for key 'lang_definition_index'<br />Error No: 1062<br />INSERT INTO language_definitions (language_id,block,section,language_key,language_value,create_date) VALUES ('0',
                          'index_home',
                          '0',
                          'heading_title',
                          "Welcome to %s",
                          NOW() ), ('0',
                          'index_home',
                          '0',
                          'text_latest',
                          "Latest Products",
                          NOW() ) in <b>/home/stock2/public_html/core/database/mysql.php</b> on line <b>86</b>
Hope this helps, have tried suggestions but still have issue. You dont have the issue with pre 1.04 versions.

 

Powered by SMFPacks Social Login Mod